Audi Q3 Owners Forum banner
21 - 23 of 23 Posts

·
Registered
Joined
·
5 Posts
Hi Cat, did you find the cause of the problem? My wife's Q3 2.0 TDI quattro (2012, 100k miles) is doing the same momentary loss of power. Unfortunately over the weekend it did also bring up the P0403 fault code which is why I'm here. When I plugged it in and took a look on data stream it's saying:
EGR_PCT 0.0%
EGR_ERR 99.2%
So I'm thinking it's going to need an EGR replacement. Just wondering if there were any other issues that may be worth doing at the same time to save labour costs. I cleaned the throttle body a few months ago when that fault code came up and I found engine shut off much cleaner and quicker since.
Been an expensive car since I bought it a year ago. New thermostat, clutch, dual mass, clutch slave and master cylinders, brake pads and discs (knew about the brakes when I bought it) and now this so any info is welcome. Thanks.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #23 ·
Im afraid not, never found out what it was, everything that should’ve been was checked or cleaned. Ended up putting it down to the only cure would be to start replacing everything which wasn’t an option. Im now back to petrol, another Q3 and extremely happy albeit missing the tork!
I would suggest a new egr valve in your case, generally if you’ve done the burn off (3rd gear 70mph for half hr on motorway) even a forced regen (if have software to do so) at 100k and a nearly 10yr old car I would. 10yr lifespan and all that, cheaper than a dpf! I would say though take to an independent vag specialist if you dont have time/ramp as its a horrible job to do, awkward and just to get to it takes forever!
I wish I could help, its one of those come to a dead end posts. Hope you get sorted, keep us posted
 
21 - 23 of 23 Posts
Top