Audi Q3 Owners Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Very little movement at accelerator pedal. Can't get above 40mph with poor acceleration. Car was OK yesterday. No warning lights or bongs. 2017 2.0TFSI DSG. 18 k miles.
 

·
Super Moderator
Joined
·
6,360 Posts
OK, silly questions first. Have you checked for foreign bodies stuck behind or under the accelerator pedal? Carpet or mat corners caught against it or anything impeding the pedal's progress? As the pedal doesn't move much it's got to be something physical (and hopefully simple) to do with the pedal assembly and/or linkage.

Anyone here aware of known problems with Q3 loud pedal issues?
 
  • Like
Reactions: -Ju-

·
Registered
2016 RSQ3 Exclusive Java green.
Joined
·
578 Posts
When you say very little movement, as in pedal travel,
It's a floor mounted pedal and you could have something stuck underneath it. Happened to me a few months back
 

·
Registered
Joined
·
1,514 Posts
Twisted mat?
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #5 ·
OK, silly questions first. Have you checked for foreign bodies stuck behind or under the accelerator pedal? Carpet or mat corners caught against it or anything impeding the pedal's progress? As the pedal doesn't move much it's got to be something physical (and hopefully simple) to do with the pedal assembly and/or linkage.

Anyone here aware of known problems with Q3 loud pedal issues?
Not a silly question and it was the first thing I checked but can't see anything.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #6 ·
Not a silly question and it was the first thing I checked but can't see anything.
Problem was a small stone jammed under the accelerator pedal.
 
  • Like
Reactions: DavidS

·
Super Moderator
Joined
·
6,360 Posts
Great! Glad it was such a simple fix.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #8 ·
Great! Glad it was such a simple fix.
The main dealer had their pound of flesh though. I need new front discs and pads despite them telling me 450 miles ago that the brakes were fine after I reported brake judder.
 

·
Registered
Joined
·
186 Posts
The main dealer had their pound of flesh though. I need new front discs and pads despite them telling me 450 miles ago that the brakes were fine after I reported brake judder.
Get a second opinion mate from a local Indy if you can. Sounds like they are having a "quiet month" and want some extra wonga in the kitty :whistle:
 
  • Like
Reactions: DavidS

·
Super Moderator
Joined
·
6,360 Posts
I'd query it too. My Q3 is the same spec as yours, four years older and with nearly 60,000 miles on the clock, still running the original discs and only had new pads last month due to a leaky caliper.
 

·
Registered
Joined
·
1,514 Posts
Discs and pads are the standard cash generator…particularly if they say thry can do them while they have the car.
Beware!!
 

·
Registered
Joined
·
316 Posts
I tend to agree with DavidS, my experience is not good with any VAG discs and or pads. Inverness Audi highlighted them for about 6 months, Stirling Audi did not flag them. If I were you I'd get an indie to verify.

Mike
 

·
Registered
Joined
·
1,514 Posts
BMW just as bad.
They tried it at about 10k on my 330i coupe!! That was 18 years ago!
 

·
Registered
Joined
·
186 Posts
Wife's company car went to Merc last week for its 1st service. Barely 4k on the clock due to Covid and work sheet said "wipers replaced due to streaking"... They were fine to me during the recent monsoon we had :unsure:. Rogues, wouldn't do that with a private customer...
 

·
Registered
Joined
·
64 Posts
My mates wife just put her Q7 into Highland Audi and they advised new discs and pads all round despite video showing only 60% worn and minimal rust.
They quoted over £1200 for front and over £700 for rear😳😳
 

·
Registered
Joined
·
316 Posts
I'm not surprised by this, living near salt water was frequently blamed.
Kenny's do decent job.

Mike
 
  • Like
Reactions: Beanjunior
1 - 17 of 17 Posts
Top